¿¿PHP-Nuke 7.9 mas insegura??

He encontrado ya en varios sitios serios de PHPNUKE que no recomiendan utilizar la versión oficial de PHPNUKE 7.9 debido a que no tiene los parches de seguridad 3.0, 3.1.
Se sabe que el Señor Burzi hace un gran trabajo con PHPNUKE, mi pregunta cual es la prisa de sacar nuevas versiones, sin al menos tener actualizaciones importantes de seguridad.

Así que la recomendación clara de varios sitios, de personas que saben de PHNUKE es que no se utilice PHPNUKE 7.9 debido a las carencias de seguridad importantes que tienen.
Es así como Bob Marion y 64BitGuy insisten tanto como que muchos otros sitios le recomiendan a sus afiliados no utilizar dicho paquete.

Noticia de Nukescripts
Noticia de 64BitGuys
Noticia de Ulsoft